티스토리 뷰
반응형
리액트 빌드 후 아파치에 배포하고자 할 때.
빌드 디렉토리를 DocumentRoot 로만 잡았더니, sub path 일때 오류가 발생했다.
virtualhost 를 아래와 같이 설정하면 된다.
<VirtualHost *:8080>
ServerName example.com
DocumentRoot /var/www/httpd/example.com
<Directory "/var/www/httpd/example.com">
...
RewriteEngine on
# Don't rewrite files or directories
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
# Rewrite everything else to index.html to allow html5 state links
RewriteRule ^ index.html [L]
</Directory>
</VirtualHost>
반응형
'서버 등 운영체제(OS) > Linux' 카테고리의 다른 글
| [Ubuntu] journal log 지우기 & 용량 제한 하기 (0) | 2020.12.24 |
|---|---|
| 우분투 20.04 업그레이드 후 오류 현상 정리 (0) | 2020.10.29 |
| How to gitlab restart (0) | 2020.02.06 |
| error: insufficient permission for adding an object to repository database .git/objects (0) | 2019.08.15 |
| [Ubuntu] socat 을 사용한 포트 포워딩 Port forwarding (0) | 2017.11.27 |
반응형
공지사항
최근에 올라온 글
최근에 달린 댓글
- Total
- Today
- Yesterday
링크
TAG
- 적금
- 아파트매매
- 2026
- etf
- ubuntu
- 출산
- 카뱅
- 대출
- php
- 고금리
- 해외주식
- 혜택
- 금융
- 세금
- 주담대
- remove
- 재테크
- 안과
- 신혼부부
- 안드로이드
- 지도
- 앱테크
- 내집마련
- 연말정산
- 우회
- 정부
- 공제
- 부동산
- 투자
- 카카오뱅크
| 일 | 월 | 화 | 수 | 목 | 금 | 토 |
|---|---|---|---|---|---|---|
| 1 | 2 | 3 | ||||
| 4 | 5 | 6 | 7 | 8 | 9 | 10 |
| 11 | 12 | 13 | 14 | 15 | 16 | 17 |
| 18 | 19 | 20 | 21 | 22 | 23 | 24 |
| 25 | 26 | 27 | 28 | 29 | 30 | 31 |
글 보관함